justin = { main feed , music , code , askjf , pubkey };
Ask Justin Frankel
No reasonable question unanswered since 2009!

Suggested topics: programming, music, sleep, coffee, etc.

Note: please do not ask questions about REAPER features, bugs or scheduling, use the forums instead.


Name: Ask: Human (enter yes):
[back to index] | [unreplied] | [replied] | [recent comments] | [all]

Question: Hi Justin, I developed a plugin for Reaper. I output the DLL and place it in the %APPDATA%/REAPER/UserPlugins folder. It works great on Windows, but on macOS platform REAPER does not load this plugin at startup. What do I have to do to run this plugin on macOS. Thank you.
Asked by Musa Kurt (185.253.121.x) on January 4 2021, 12:50pm
Reply on January 4 2021, 9:27pm:
    Hmm a lot of possibilities of why it might not get loaded. is it reaper_xyz.dylib, in your ~/Library/Application Support/REAPER/UserPlugins/ folder? Does it have any GateKeeper quarantine metadata set from having been downloaded? Does it get loaded at all? Are there unresolved symbols? Try running REAPER from a console and see if it prints anything?


Comments:
  • Posted by Musa Kurt (185.253.121.x) on January 5 2021, 11:49am:
    I made the DLL library into .dylib with g ++ CLI. I placed it in the folder you mentioned in macOS. But REAPER application does not install this plugin. When I run the REAPER application from the console, no output appears. Sorry I don't have enough control over both Mac and cpp.

  • Posted by Mespotine (80.187.107.x) on January 5 2021, 12:17pm:
    Best is to ask in the developer section of the Reaper Forum. There are plenty of people with a lot of experience bout that.

  • Posted by Musa Kurt (88.231.56.x) on January 5 2021, 1:09pm:
    Thanks for help. I have now created a new thread.


Comment:
    Your Name:   -- Site Owner's Name:  (for human-verification)

    Comment:    

    
  
[back to index] | [unreplied] | [replied] | [recent comments] | [all]
Copyright 2021 Justin Frankel. | RSS